Автоматизированная система учета для организации, занимающейся розничной торговлей медпрепаратами - курсовая работа готовая
Приём заказов:
Круглосуточно
Москва
ул. Никольская, д. 10.
Ежедневно 8:00–20:00
Звонок бесплатный

Автоматизированная система учета для организации, занимающейся розничной торговлей медпрепаратами

Диплом777
Email: info@diplom777.ru
Phone: +7 (800) 707-84-52
Url:
Логотип сайта компании Диплом777
Никольская 10
Москва, RU 109012
Содержание

КОМИТЕТ ПО ОБРАЗОВАНИЮ МИНГОРИСПОЛКОМА

УЧРЕЖДЕНИЕ ОБРАЗОВАНИЯ

МИНСКИЙ ГОСУДАРСТВЕННЫЙ КОЛЛЕДЖ ЭЛЕКТРОНИКИ

Специальность: 2-40 01 01

“Программное обеспечение информационных технологий”

ПОЯСНИТЕЛЬНАЯ ЗАПИСКА

“Автоматизированная система учета для организации, занимающаяся розничной торговлей медпрепаратами “

НА КУРСОВОЕ ПРОЕКТИРОВАНИЕ

2011

Содержание

  • Введение
  • 1. Назначение и область применения
  • 2. Практическая часть
  • 2.1 Постановка задач
  • 2.2 Выбор среды разработки
  • 2.3 Вычислительная система
  • 2.4 Тестирование и отладка программы
  • 2.5 Описание программы
  • 2.5.1 Входные данные
  • 2.5.2 Выходные данные
  • Заключение
  • Список использованных источников
  • Приложения

Введение

1С: Предприятие является системой программ для автоматизации различных областей экономической деятельности. В конкретный программный продукт, входящий в систему программ 1С: Предприятие, включаются те функции и возможности, которые отвечают назначению этого продукта.

Данный программный продукт предназначен для автоматизированной системы учета для организации, занимающаяся розничной торговлей медпрепаратами. Он позволяет:

– вести учёт принятых и уволенных сотрудников;

– вести учёт материалов

– вывод документов на печать;

– создание отчётов.

Данная работа является курсовым проектам учащегося МГК электроники четвёртого курса, разработанная на основе теоретических и практических знаний по дисциплине “Автоматизация управленческой деятельности организации”. Для реализации поставленной задачи была использована конфигурация и встроенный язык в 1С: Предприятие.

В разработке курсового проекта были применены все знания в программе 1С: Предприятие, полученные на практических занятиях, а также изученные самостоятельно.

программа учет тестирование отладка

1. Назначение и область применения

Для реализации курсового проекта по дисциплине “Автоматизация управленческой деятельности организации” была поставлена задача – создать конфигурацию “Автоматизированная система учета для организации, занимающаяся розничной торговлей медпрепаратами”.

Предполагается, что программа будет использована в компаниях предлагающих услуги по продаже медпрепаратами;

– Конфигурация должна содержать справочники: сотрудники, должности, поставщики, покупатели, перечень товара.

Конфигурация должна содержать документы: приём на работу, увольнение, продажа товара, поступление товара.

Вся информация должна поддаваться просмотру и редактированию;

Программа должна формировать список оказанных услуг, предоставляемых предприятием, в виде вывода на печать.

Программа должна предоставить вывод информации о клиентах, работников и других данных предусмотренных программой.

2. Практическая часть

2.1 Постановка задач

Для реализации курсового проекта по дисциплине “Автоматизация управленческой деятельности организации” была поставлена задача – создать автоматизированную систему учета для организации, занимающейся розничной торговлей медпрепаратами. За основу создания информационной базы были взяты различные справочники и соответствующие книжные издания.

· Конфигурация должна содержать документы: сотрудники, должности, поставщики, покупатели, перечень товара;

· Вся информация должна поддаваться просмотру и редактированию;

· Программа должна формировать список оказанных услуг, предоставляемых предприятием, в виде вывода на печать.

· Программа должна предоставить вывод информации о клиентах, работников и других данных предусмотренных программой.

Структурная схема программы показана на рисунке 2.1

Входная информация Выходная информация

Рисунок 2.1 – Структурная схема программы

2.2 Выбор среды разработки

Система программ 1С: Предприятие предназначена для решения широкого спектра задач автоматизации управления и учета и позволяет построить индивидуальную информационную систему, учитывающую задачи и особенности каждого предприятия.

Основной особенностью системы 1С: Предприятие является её конфигурация. Собственно система 1С: Предприятие представляет собой совокупность механизмов, предназначенных для манипулирования различными типами объектов предметной области. Конкретный набор объектов, структуры информационных массивов, алгоритмы обработки информации определяет конкретная конфигурация. Вместе с конфигурацией система 1С: Предприятие выступает в качестве уже готового к использованию программного продукта, ориентированного на определённые типы предприятий и классы решаемых задач.

Конфигурация создаётся штатными средствами системы. Обычно конфигурация поставляется фирмой-разработчиком в качестве “типовой”, но может быть изменена, дополнена пользователем системы, а также разработана заново.

Система 1С: Предприятие имеет компонентную структуру. Часть возможностей, предоставляемых системой для решения задач автоматизации, является базовыми, то есть поддерживается в любом варианте поставки системы. Это, прежде всего, механизмы поддержки справочников и документов. Другие возможности реализуются компонентами системы: например, ведение списка бухгалтерских счетов. Таким образом, состав установленных компонентов определяет функциональные возможности системы.

2.3 Вычислительная система

1С может запускаться в четырех режимах:

Предприятие – режим использования информационной базы. В этом режиме работают обычные пользователи, вводят данные, печатают отчеты и т.д. В этом режиме нельзя редактировать структуру конфигурации.

Конфигуратор – режим конфигурирования (программирования). В этом режиме работают программисты, создают новые справочники, отчеты, пишут программные модули. Вводить данные в информационную базу в этом режиме нельзя.

Монитор – режим наблюдения за пользователями, работающими в данный момент с информационной базой. Все операции с информационной базой регистрируются в Журнале регистраций. В режиме Монитор можно получить протокол всех операций совершенных конкретным пользователем, над конкретным объектом, а также можно задать другие условия фильтра.

Отладчик – режим для программистов, когда у них что-то не ладится с программой. Здесь можно отследить как выполняется программа буквально по шагам. При этом программа выполняется в режиме Предприятие.

Рисунок 2.2 – Главное окно 1С Предприятия

Конфигуратор представляет собой специальный режим запуска системы 1С: Предпритие 7.7 Этот режим позволяет выполнять изменение существующих прикладных решений и создание новых, а также выполнять действия по администрированию информационной базы. Конфигуратор может быть вызван прямо из окна запуска 1С: Предприятия:

Конфигуратор предоставляет разработчику все необходимые инструменты для “визуального” описания структуры прикладного решения, создания форм диалогов и выходных документов, механизмов работы пользователей с данными (интерфейсов) и прав доступа различных групп пользователей к различной информации. Кроме этого конфигуратор позволяет создать и настроить взаимодействие различных элементов прикладного решения друг с другом и написать модули на встроенном языке для обработки различных событий и реализации специфических алгоритмов взаимодействия, обработки входных и выходных данных.

Конфигуратор системы 1С: Предприятие является специальным режимом запуска 1С и предназначен для разработчиков, программистов. В этом режиме разработчик создает или корректирует структуру базы данных, программные модули, производит административные работы. В режиме Конфигуратора нельзя вводить информацию в базу данных, за исключением загрузки базы данных из архивов. Обычные пользователи работают в другом режиме “Предприятие”. В этом режиме возможен ввод данных, заполнение справочников и ввод документов, формирование отчетов и запуск обработок. В режиме Предприятие нельзя редактировать структуру конфигурации.

Итак, основное правило:

В режиме Конфигуратор – мы определяем структуру базы данных и пишем программы.

В режиме Предприятие мы используем программы и вводим данные.

Дерево конфигурации (метаданные)

В окне конфигурации можно раскрывать списки объектов (константы, справочники, документы и т.д.). Объекты можно добавлять, удалять, редактировать, изменять их порядок, сортировать, писать для них описание.

Каждый объект имеет свойства и контекстное меню (вызывается правой кнопкой мыши).

Также к конфигурации относятся Интерфейсы и Права. Для их вызова нужно щелкнуть вкладки, расположенные внизу дерева конфигурации.

Кроме того, когда окно дерева конфигурации активно в меню Действия становятся доступными пункты “Глобальный модуль”, “Общие таблицы” и “Библиотека картинок”.

Редактор форм

У многих объектов конфигурации есть экранные формы. В частности экранные формы в версии 7.7 имеют справочники, документы, журналы документов, отчеты, обработки, журналы расчетов, журнал операций, журнал проводок, план счетов и счет. У некоторых объектов может быть несколько экранных форм, например, у справочников есть формы списков, форма элемента и форма группы.

Редактор программных модулей

У каждой экранной формы есть программный модуль. Кроме того, есть программные модули документов и глобальный модуль. В этих модулях располагается программа на встроенном языке 1С, который похож на Бейсик, но имеет свои особенности.

В программном модуле имеется синтаксическая подсветка. Разными цветами отображаются ключевые слова, переменные, комментарии и значения. Цветовая палитра настраивается в параметрах.

Шаблоны предназначены для облегчения нелегкого труда программиста. Чтобы не писать длинные конструкции, а заменять их короткими словами. При этом при вводе такого сокращения оно автоматически заменяется на полную конструкцию.

У отчетов есть печатные формы, это понятно. У документов также есть печатные формы, это тоже понятно. Но печатные формы могут быть и у других объектов: справочников, журналов документов, плана счетов и т.д. Фактически у любого объекта, у которого есть экранная форма, может быть одна или несколько печатных форм.

Печатные формы состоят из ячеек, в которых содержатся текст или формулы, что очень напоминает Microsoft Excel. Печатные формы формируются на встроенном языке 1С при помощи вывода секций. В печатной форме может не быть секций вообще, тогда можно вывести или все, или ничего. Но в большинстве случаев нужно выводить какую-то повторяющуюся часть много раз, например список сотрудников, список товаров и т.д. Секции могут быть горизонтальными и вертикальными.

У каждой ячейки есть свойства, которые вызываются правой кнопкой мыши

Обычно пользователи спокойно работают с базой данных, пока вы вносите какие-то изменения в свою локальную копию. Потом вы загружаете измененную конфигурацию в рабочую базу и пользователи начинают испытывать блаженство от ваших изменений.

Когда нужно сохранить некоторые особенности оригинальной конфигурации, то применяют этот режим. При этом анализируются различия между конфигурациями и настраивается режим объединения.

2.4 Тестирование и отладка программы

Конфигурация тестировалась в течение 2-х недель в таблице 1 представлена информация тестирования конфигурации:

Таблица 2.1 – Тестирование конфигурации

№ п/п

Действие

Результат

1

Запуск 1С

Загрузка 1С

2

Выбор режима нажатие на кнопку “ок”

Переход к 1С предприятию начало работы

3

Выбор вводимого документа

Успешное открытие документа

4

Добавление записи

Открытие формы заполнения

5

Заполнение документа и его проводка

Удачное заполнение документа и его проводка

6

Вывод отчетов при установке различных дат

Вывод информации корректен

7

Добавление записей в справочники

Корректное дополнение справочников

8

Просмотр журнала и перепроводки

Корректно

Результат тестирования показал, что конфигурация работает на все 100%.

2.5 Описание программы

Для работы с конфигурацией необходимо: запустить программу 1С Предприятие, добавить конфигурацию, хранящуюся в каталоге “PRG”. Появится главная форма, которая имеет вид в соответствии с рисунком 2.1.

Рисунок 2.1 – Главная форма

В программе имеется горизонтальное меню с пунктами: “Файл”, “Операции”, “Справочники”, “Документы”, “Отчеты”, “Сервис”, “Окна”, “Помощь”. В каждом из которых имеется подпункты меню:

В пункте “Файл” находятся подпункты: “Новый”, “Открыть”, “Выход”.

В пункте “Операции” находятся подпункты: “Журнал документов”, “Справочники”, “Константы”, “Отчеты”, “Обработка”, “Удаление помеченных документов”, “Поиск ссылок на объекты”, “Проведение документов”, “Управление операционными итогами”;

В пункте “Справочники” находятся подпункты: “Сотрудники”, “Должности”, “Поставщики”, “Покупатели”, “Перечень медпрепаратов”;

В пункте “Документы” находятся подпункты: “Прием на работу”, “Увольнение”, “Продажа товара”, “Поступление товара”;

В пункте “Сервис” находятся подпункты: “Калькулятор”, “Календарь”, “Табло”, “Временная блокировка”, “Параметры”, “Панель инструментов”;

В пункте “Отчёты” находятся подпункты: “Остатки материалов”, “отчёт о имеющихся материалах”;

В пункте “Окна” находятся подпункты: “Закрыть окно сообщений”, “Панель окон”, “Окна”;

В пункте “Помощь” находятся подпункты: “Помощь”, “Содержание”, “Общее описание”, “Окна”, “Советы дня”, “О системе 1С Предприятие”, “О программе”;

Программа разрабатывалась преимущественно для пользователей с низким уровнем владения компьютера, поэтому обладает более удобным, упрощенным и понятным интерфейсом.

2.5.1 Входные данные

Входными данными является содержимое справочников и документов, которые находятся в конфигураторе. Структура справочников и документов представлена на рисунках 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9, 2.10.

Рисунок 2.2 – Справочник “Сотрудник”

Рисунок 2.3 – Справочник “Должности”

Рисунок 2.4 – Справочник “Поставщики”

Рисунок 2.5 – Справочник “Покупатели”

Рисунок 2.6 – Справочник “Перечень медпрепаратов”

При помощи конфигуратора были разработаны следующие справочники:

Справочник “Сотрудники”:

– Наименование – Фамилия с инициалами;

– Должность – должность сотрудника;

– Оклад – зп сотрудника;

– Дата Приема – дата приема на работу сотрудника;

– Дата Увольнения – дата увольнения с работы сотрудника.

Справочник “Покупатели”:

– Наименование – название покупателя;

– Адрес – адрес покупателя;

– Телефон – телефон покупателя.

Справочник “Поставщики”:

– Наименование – название покупателя;

– Адрес – адрес покупателя;

– Телефон – телефон покупателя.

Справочник “Должности”:

– Наименование – название должности;

Справочник “Перечень товара”:

– Наименование – название товара;

– Цена – цена товара;

– НДС – НДС на товар;

Документ “Продажа товара”

– Покупатель – наименование покупателя;

– Наименование – название товара;

– Количество – количество товара;

– Цена – цена товара;

– Ставка НДС – НДС на товар;

– НДС – налог в деньгах;

– Сумма – сумма НДС и цены.

Документ “Поступление товара”:

– Поставщик – наименование поставщика;

– Наименование – название товара;

– Количество – количество товара;

– Цена – цена товара;

– Ставка НДС – НДС на товар;

– НДС – налог в деньгах;

– Сумма – сумма НДС и цены.

Документ “Приём на работу”:

– Дата – дата приёма на работу сотрудника;

– ФИО – ФИО сотрудника;

– Должность – должность сотрудника.

Документ “Увольнение”:

– Дата – увольнения сотрудника

– ФИО – ФИО сотрудника

Заключение

Таким образом, в данном курсовом проекте была разработана конфигурация, которая автоматизирует работу организации, занимающаяся розничной торговлей медпрепаратами. Задача была успешно выполнена. В процессе разработки были созданы: справочник, документы и др.

В будущем планируется доработать конфигурацию добавить новые запросы и сделать сетевую версию. Это будет возможно, так как 1С: Предприятие является открытой компонентной программой.

Список использованных источников

1. Ощенко И.А.Д. Азбука программирования в 1С: Предприятие 7.7 – СПб.: БХВ-Петербург, 2008. – 528 с;

2. Габец А.П., Гончаров Д. И.1С: Предприятие 8.1 Простые примеры разработки – электронная версия, 2009. – 579;

3. Постовалов С.Н., Постовалова А. Ю.1С: Предприятие 7.7 Уроки программирования. Самоучитель – СПб.: БХВ-Петербург, 2009. – 320 с;

4. Конспект по курсу “Автоматизированное управление деятельности предприятия”.

Приложения

Приложение А

Процедура Подбор ()

ОткрытьПодбор (“Перечень_Медпрепаратов”,”ФормаСписка”);

КонецПроцедуры

Процедура ЗапросКоличестваВПодборе (Выб)

Если Выб. ПометкаУдаления () =1 Тогда

Предупреждение (“Нельзя выбирать помеченные на удаление товары!”);

Возврат;

КонецЕсли;

Кол=1;

Если ВвестиЧисло (Кол,”Введите количество”,10,2) =1 Тогда

НоваяСтрока ();

Наименование=Выб;

Количество=Кол;

Цена=Выб. Цена;

Ставка_НДС=Выб. НДС;

НДС = (Кол * Цена) / 100 * Ставка_НДС;

Сумма = Кол * Цена + (Кол * Цена) / 100 * Ставка_НДС;

КонецЕсли;

КонецПроцедуры

Процедура ОбработкаПодбора (Выб);

ЗапросКоличестваВПодборе (Выб);

АктивизироватьСтроку ();

КонецПроцедуры

Процедура Печать ()

Таб = СоздатьОбъект (“Таблица”);

Таб. ИсходнаяТаблица (“Таблица”);

Таб. ВывестиСекцию (“Шапка”);

ВыбратьСтроки ();

Пока ПолучитьСтроку () =1 Цикл

Таб. ВывестиСекцию (“Основная”);

КонецЦикла;

Таб. Опции (0,0,0,0,”ОпцииПечатиМ4″,”ОкноМ4″);

Таб. ТолькоПросмотр (1);

Таб. Показать ();

КонецПроцедуры

Процедура ПриОткрытии ()

ПриЗаписиПерепроводить (1);

КонецПроцедуры

Запрос = СоздатьОбъект (“Запрос”);

ТекстЗапроса = “

|Долж = Справочник. Сотрудник. Должности;

|Группировка Долж упорядочить по Долж. Наименование;

|”;

Запрос. Выполнить (ТекстЗапроса);

Пока Запрос. Группировка (“Долж”) =1 Цикл

Сообщить (Запрос. Долж);

КонецЦикла;

Процедура Сотрудники ()

Таб = СоздатьОбъект (“Таблица”);

ДатаОтчета = ТекущаяДата ();

;

Таб. ИсходнаяТаблица (“Таблица”);

Сотрудн = СоздатьОбъект (“Справочник. Сотрудник”);

Таб. ВывестиСекцию (“Шапка”);

Сотрудн. ИспользоватьДату (ДатаОтчета);

Сотрудн. ПорядокНаименований ();

Сотрудн. ВыбратьЭлементы (0);

Пока Сотрудн. ПолучитьЭлемент () =1 Цикл

Если Сотрудн. ЭтоГруппа () = 1 Тогда

Продолжить;

КонецЕсли;

Таб. ВывестиСекцию (“Строка”);

КонецЦикла;

Таб. ТолькоПросмотр (1);

Таб. Показать (“”);

КонецПроцедуры

Процедура Товары ()

Таб = СоздатьОбъект (“Таблица”);

;

Таб. ИсходнаяТаблица (“Таблица1”);

Товар = СоздатьОбъект (“Справочник. Перечень_Медпрепаратов”);

Таб. ВывестиСекцию (“Шапка”);

Товар. ПорядокНаименований ();

Товар. ВыбратьЭлементы (0);

Пока Товар. ПолучитьЭлемент () =1 Цикл

Если Товар. ЭтоГруппа () = 1 Тогда

Продолжить;

КонецЕсли;

Таб. ВывестиСекцию (“Строка”);

КонецЦикла;

Таб. ТолькоПросмотр (1);

Таб. Показать (“”);

КонецПроцедуры

Приложение Б

Примеры форм программы

Рисунок 1 – Авторизация доступа

Рисунок 2 – Приём на работу

Рисунок 3 – Увольнение

Рисунок 4 – Поступление товара

Леонид Федотов
Леонид Федотов
Окончил НИУ ВШЭ факультет компьютерных наук. Сам являюсь кандидатом наук. По специальности работаю 13 лет, за это время создал 8 научных статей и 2 диссертации. В компании подрабатываю в свободное от работы время уже более 5 лет. Нравится помогать школьникам и студентам в решении контрольных работ и написании курсовых проектов. Люблю свою профессию за то, что это направление с каждым годом становится все более востребованным и актуальным.
Поделиться курсовой работой:
Поделиться в telegram
Поделиться в whatsapp
Поделиться в skype
Поделиться в vk
Поделиться в odnoklassniki
Поделиться в facebook
Поделиться в twitter
Похожие статьи
Раздаточный материал для дипломной работы образец

Когда студент выходит на защиту перед экзаменационной комиссией, ему требуется подготовить все необходимые материалы, которые могут повысить шансы на получение высокого балла. Один из таких

Читать полностью ➜
Задание на дипломную работу образец заполнения

Дипломная — это своеобразная заключительная работа, которая демонстрирует все приобретенные студентом знания во время обучения в определенном вузе. В зависимости от специализации к исследовательским работам

Читать полностью ➜